Request for fixes

Thank you for that. That button doesn't appear for me. I do not know why.
Just a shot in the dark, do you have the add-on ''NoScripts'' on your browser? If so, you have to allow scripts so as to see those buttons. Best of luck
The upload feature is not in the toolbar; it is a button to the lower right of the editor window, thus:

View attachment 1937

Thank you, sir. There is a switch in our preferences, somewhere, that activates the advanced editor; I've lost track of that simply because I've never really used it. I don't know if I even knew what the XenForo advanced editor looks like, except I must have, because at some point I remember setting my preferences to the simple editor, and haven't really thought about it, since. Even looking around my current posting screen, I don't see the option to activate the advanced editor, which in turn means it must be glaringly obvious.
Yes, I checked that before responding. Even with basic editor, I still see the Upload File link.

I finally found a button; it's right there, if I am sending a private message. I don't have it on my editor for posting.


Top: Moderator posting controls. Bottom: Conversation (private) message controls.