Strange case of lost text

Discussion in 'Computer Science & Culture' started by DNA100, Nov 17, 2015.

  1. DNA100 Registered Senior Member

    Messages:
    259
    In the absence of MS word, I often use .rtf files to save data.

    That is what I was doing.

    Most of these files are like lists with images.
    For example:

    1.[ Name of Animal 1]
    [image of Animal 1]


    2.[ Name of Animal 2]
    [image of Animal 2]

    3.[ Name of Animal 3]
    [image of Animal 3]

    ... and so on.


    I have been working with one such file for a while.
    Now let's say yesterday I added 25 to 35 and saved.
    Today when I reopened the .rtf file, much of the text is gone and only say 1 to 10 remain.

    Now I work hard and re-add 10-20 from my poor memory. Save it again.
    I copy the text with ctrl+A and ctrl+C and try to paste it in another .rtf file as a backup.
    It doesn't paste!
    So I closed the .rtf file and copy it as a whole and create a backup file.
    Numbers 10-20 are still missing in the backup!!
    Now I reopen the original file.
    I find that numbers 10-20 are gone even in the original!!!

    In other words, nothing that I type/paste into the file are being saved!

    Is there a way I can get all the data that I typed yesterday back, or at the very least how can I ensure that the data that I insert will be saved?
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Billy T Use Sugar Cane Alcohol car Fuel Valued Senior Member

    Messages:
    23,198
    I can't help you, but LibreOffice is free and can save files in many different ways, including with ".doc" extension. I often use it because for strange reason, that takes up only about 50% of the memory space that saving in their own format does. After using the version I down loaded more than two years ago last month, I downloaded their more modern version.

    It's version of Excel now has a graphing ability too. I am just learning how to use it. It can plot multiple curves on one 2D xy grid, assigning each a different color, and has a wide set of choices (points only, points connected by straight line segments, or with third order curve fit), but if you can have one plot with points only and another with a continuous curve, I have not discovered how.

    They do ask for a donation to support their development work, with as I recall $10 the least suggestion, but it is not manditory.
     
    DNA100 likes this.
  4. Google AdSense Guest Advertisement



    to hide all adverts.
  5. DNA100 Registered Senior Member

    Messages:
    259
    OK, thanks for your advice.
     
  6. Google AdSense Guest Advertisement



    to hide all adverts.
  7. Stryder Keeper of "good" ideas. Valued Senior Member

    Messages:
    13,102
    In the logic of most problems there is something called "File Locking". The idea is that if a file is being accessed in Read/Write mode that it should be locked to that one instance to stop occurrences of data being changed by another program or process. This often means when one is file is locked to Read/Write mode for one process any subsequent processes can only access in Read only mode. It's possible that you've had a read/write occurrence left open in the background, while you've been editing a read only twin process. So the information isn't being written to the file.

    You need to make sure that you haven't left old processes running or accidentally started a new one to make sure this isn't the case. I hope that's of use.
     
  8. Billy T Use Sugar Cane Alcohol car Fuel Valued Senior Member

    Messages:
    23,198
    Thanks. I did a Boot Scan and found three files here were corrupted and suspect that is the problem. The were all files in
    C:/windows/ServiceProfiles/NetworkServices/AppData/Local/Temp/mpam/
    then 4f79381 and 593fb703 and a48b6824

    Note I'm using wife's computer with a Brazilian Keyboard. All my / should be flipped the other way, but I can not find how to make that on her keyboard. When I hit the key marked that way, I get: ]

    Her computer is also using windows 8.1 so I coppied its files in: C:/windows/ServiceProfiles/NetworkServices/ and not down lower levels as my next level down was /AppData/ but her's was not.
    Copied to my pin (thumb) drive were about 104 files, but it told me it could not copy three as they were in use. They were
    NTUSER.DAT and two subfiles of it called
    .LOG1 and .LOG2

    My idea was to rename my C:/windows/ServiceProfiles/NetworkServices/AppData/Local/Temp123/mpam/ (or what ever C:/windows..... goes down to with this inserted 123 and then copy from the pin drive into my C:/windows .... And see it my computer would then reach the internet. I could always remove the file I copied in and the 123 to get back no worse than I am now, I think, but am worried that missing the three NTUSER.DAT files might completely kill my computer. I have several things I am using it for - production of some graphs from data in it for better visual understanding.

    Wife has another computer with problems too, but not as bad as mine. She gets the DNS can not find number = to name msg about half the time also, so we expect our Geek to arrive later to day. I will wait to see what he wants to do, but offer him my pin dirve with all but the three NTUSER.DAT files in it if he thinks it can help.
     
  9. Billy T Use Sugar Cane Alcohol car Fuel Valued Senior Member

    Messages:
    23,198
    All seems to be well now and I did nothing. Our "Geek" could not come today as planned. I'll call telling he need not come. I realized MS must be able to get into my computer, even when I can't get to any site (as they keep putting up a new pretty photo even before I log-on).

    I guess they did some up-date to and that fixed the problem. Thanks again.

    Wife's badly behaving at times computer uses Win 7. Can it still be down loaded? That might fix her's too.
     
  10. Billy T Use Sugar Cane Alcohol car Fuel Valued Senior Member

    Messages:
    23,198
    Still working fine despite new "boot scan" showing same three files are "corrupted." I copied down more about them:
    They are:exe|>mpavd1ta.vdm
    and error is 42127 {CAB archieve is corrupted}

    I assume from the name these files never were my problem - just some Archives I never use, but perhaps the system tried to and got locked up some way. I wish I knew how it got fixed.
     

Share This Page